Blinkup failing for Bridge - Certificate pinning failure


#1

My Bridge seems to have stopped working recently.

I thought perhaps I needed to reconfigure it. I started the process to add the bridge, typing the serial number and then my wifi password and then “Start Blinkup”. Immediately after clicking “Start Blinkup”, I get the enclosed screen, and blinkup never happens.

It looks as if there is some problem with some certificate, presumably on the server side.

I’m running this on Android 8.1 on a Pixel 2 XL with the July 5, 2018 security patch level. I’m running the 3.5.16 version of the app.

[An unrelated note: Notifications continue to not work on Android for me. I suspected and suggested this was a server side certificate problem – obviously not the same one since it would be a Google notifications certificate – but indicative of the problem that certificates periodically expire and need to be renewed.]


#2

Paging @cameron.

On a side note, my Bridge is still functioning, haven’t tried to re-blink it recently.


#3

Same thing happened to me. We got a new wifi system and had to sync it up with the new passwords etc. I sent an email to support with the same image that was posted above. Not sure why I thought I would get a response. Still have heard nothing.

However! This is unique to Android. I used my wife’s iPad and the blinkUp worked just fine. .


#4

Thanks for that suggestion. I had an iPad lying around and I was able to successfully get blinkup to work using the iOS version of the app. However, the Android version still needs to be fixed. You don’t have a product if there’s no functional Android version of the app.

I had the Lockitron app already installed on the iPad. However, when I looked on the Apple App store to see if there was a newer version, it seems there was no Lockitron app available for iPad anymore, at least not for my iOS 9.3.5 iPad. This is the latest version of iOS available for this iPad Mini hardware. (I don’t have an iPhone or a newer iPad so I can’t check that.)


#5

@jjd - I just checked the App Store, the latest version is 3.5.15, released about a month ago. It says it supports devices with iOS 8.0 or newer.

Did you make sure to check that the store search was for iPhone apps, not specifically iPad apps? I ask because I know it works on iPad, but I don’t believe it has an iPad layout.


#6

Yes, that was the problem. Being an Android person, I didn’t see that the default on the iPad (iPad only) was set. If you can load iPhone apps on an iPad, you think the default would be “Any” – a setting that doesn’t exist in the App Store UI. Heading back to Android now…


#7

Same for me and no access to an iphone or pad. Very poor