General connection problems


#1

I’ve had connection issues with my android phone (Nexus 6P) using both bluetooth and using the bridge. The app is really unreliable about connecting to the lock. I wait and eventually I restart my phone which sometimes gets it connected. Sense is really unreliable also. I’ve stood outside my door staring at the app waiting for it to connect so I can manually press the unlock (or lock) button, but eventually pull out my key. Once inside the house i’ll get the message that sense successfully unlocked my door.

The bridge never seems to work quite right no matter where I’ve put it in the house. Both the bluetooth and wifi are listed as good. A lot of times the app will show that it’s connected to the lock via wifi, but when I press lock or unlock it’ll tell me the bridge is down and to connect via bluetooth but the wifi/bluetooth toggle button wont work.

I’ve tried just disconnecting the bridge and going strictly off bluetooth and get the same connection issues. A lot of waiting for the connection to be established.

My wife has the same issues using her android phone as well.


#2

I’ve had connection issues with my android phone (Nexus 6P) using both bluetooth and using the bridge. The app is really unreliable about connecting to the lock. I wait and eventually I restart my phone which sometimes gets it connected. Sense is really unreliable also. I’ve stood outside my door staring at the app waiting for it to connect so I can manually press the unlock (or lock) button, but eventually pull out my key. Once inside the house i’ll get the message that sense successfully unlocked my door.

Sense and being able to connect in the foreground are very closely linked; if you’re having trouble in the foreground you will definitely have trouble in the background. What OS version?

The bridge never seems to work quite right no matter where I’ve put it in the house. Both the bluetooth and wifi are listed as good. A lot of times the app will show that it’s connected to the lock via wifi, but when I press lock or unlock it’ll tell me the bridge is down and to connect via bluetooth but the wifi/bluetooth toggle button wont work.

Can you post the values from your Bridge diagnostics screen? And let me know how close Bridge is to your router? (any repeaters?)


#3

Android 7.1.1

Wi-fi signal strength -20dBm
Bluetooth signal strength -61dBm

The bridge is about 10-15 feet straight line from the lock with a wall between them. It was the area that got me the best values. No repeaters, just modem and router.


#4

@Omar_Cataldo that WiFi signal strength actually looks too strong; how close is Bridge to the router?


#5

Router is in the same room as the bridge, maybe 9 feet away.
Finding a place further away from the router might resolve this issue?
Is there a way to improve this without moving either?

This connection issue also existed when I wasn’t using the bridge at all


#6

@Omar_Cataldo do you have any iOS devices you can test with? They’re generally a good baseline when there are issues on Android. You can also try a firmware update.


#7

I have an Ipad. What do I do to test it?

I have the latest public firmware, would the beta maybe help?


#8

@Omar_Cataldo let’s test with the iPad first; install the Lockitron app (note it’s an iPhone app and you need an iPad with Bluetooth Low Energy, i.e. iPad 3+ or any iPad Mini).


#9

Ok, it’s installed. I was messing around with it and i noticed it kept switching from wifi to bluetooth


#10

@Omar_Cataldo test the iPad with WiFi/cell turned off. Can it connect to the lock and hold that connection for a minute?


#11

I turned off wifi on the ipad(didn’t see a cell option) and opened the app. It said “attempting to connect” with a spinning circle. it stayed like that for a minute or so before I decided to check it on my phone. It showed the same thing so i decided to try restarting the phone to see if that would help. The phone restarted and as soon as it came back up, the ipad connected to the lock and was able to maintain a connection.

After that it stayed connected for a minute without issues.


#12

@Omar_Cataldo ok, only one device can connect at a time. Sounds like the problem is with the Nexus 6P and 7.1.1; we’ve had a couple reports of issues with 7 and are looking into it.