Handedness Flipping


#1

Something I noticed today; my Lockitron seems to have reversed it’s handedness on its own.

This is a problematic for 2 reasons:

  • the Lockitron mis-reports lock state
  • most importantly (because of my calibration settings) that it now unlocks only half way meaning the door can not be unlocked.

I’m unclear if this change is a bug in the cloud (which I haven’t touched since the last time I believe this happened a few months ago), or if this is a bug in the firmware pushing the state to the cloud.

Has anyone else noticed this?


#2

@ged this should have been resolved through one of the last firmware updates, however, it can also indicate that the memory on the unit is corrupting. Can you see if the firmware version number reports something like “0”?


#3

Firmware Version 1418069060 is what the dashboard says


#4

@ged after resetting handedness, is it functioning as expected? Has this re-occurred?


#5

Yes, it works as it did before after resetting the handedness. I believe it may have happened once a few months ago, at the time I thought the calibration settings were messed up, so I stepped through reinstalling the lock to the door and reconfiguring it which probably had me flip the handedness.

This time while debugging with my phone, I noticed that the app said locked when it was “half-locked” and unlocked when it was fully locked. Which lead me to look at the handedness and toggle that back to the correct value.


#6

It just reoccurred with firmware 1449200870 today.

I don’t know what triggers it, it might be sudden loss of power (though I don’t know why this would be the case).

Currently have a Wemo switch power cycle the lockitron (which is connected to a 2A / 5v usb charger via battery adapter) 4 times a day to counteract random bouts of unresponsiveness that occur from time to time.

The website also shows the handedness as being incorrect as well (I’m going to fix it in a minute). It seems to me that the unit should be reading that value from the website and the website should not accept a handedness change from the unit (i.e. read-only from User Agent lockitron v2). Unless there’s a bug on the server-side that is causing this and the unit is picking it up.


#7

Argh… on the 3:59-4:00pm (Eastern) power cycle the unit failed to boot-up… Green Wifi light blinked a few times and then it was dead. Manually recycled power and it’s back and it still remembers its handedness.

Is there a way to tell remotely if the unit has failed a boot-up? That way, I could write a script to deal with the problem.


#8

@ged - first thing that comes to mind, if your lock is on all the time and doesn’t sleep, use the “lock-offline” activity to see if it’s connected/not connected.

See: https://api.lockitron.com/#kinds


#9

It’s doing it again today, flipping the handedness, it seems to being trying to destroy the lock by pushing so hard that even with the power turned off the lock is stuck either open or closed. Argh… why the hell does this keep happening?


#10

It looks like my lock now believes clockwise is actually counter-clockwise and vice versa… wtf :\


#11

Yep same problem, resetting the handedness doesn’t fix it


#12

seems like theirs alot of handedness issues on the server side.


#13

Reinstalling the latest firmware (despite already having done this), with the lock set to the proper handedness, fixed the problem for me.


#14

@Ekan Bolt or Crowdfunded?

I recommend we have two different threads; while both tie into the server and apps, it’s really tricky to pin down a bug when we don’t know which version has it.

We’re working on a known Bolt firmware issue; setting the handedness on the lock itself works fine but via the app does not.

There were a number of ongoing handedness issues with the crowdfunded Lockitron; I don’t have a good answer here. You may need to have a “swapped” setting via the app to be in the correct state. This is easy to determine when next to the lock and sending the command.


#15

The thread predates the existence of the bolt, if I can figure out how to edit the title to indicate crowdfunded, I’ll do that.

In the most recent case I was also forced to login to the website and flip the handedness back and forth with some lockitron restarts to resolve the issue. I tried with the app prior to that and was not successful, so the app might not be working for either version of lockitron.

This still doesn’t explain why the heck the lock is getting confused and flipping in the first place.

It’s pretty frustrating when the lock power cycles, flips handedness and then attempts to get back to its previous lock state (oh, my handedness flipped? That means I’m no longer unlocked, but I’m supposed to be, let me just go ahead and unlock now) and in the process seizes the motor/wedges the bolt into the door jam while screaming the motor with such force that the deadbolt can not be unlocked even when the power is pulled from the lockitron. Really not good when manual override can no longer be used.


#16

So, it’s happening again, the app shows unlocked, but the lock is physically locked… argh!

How can this be fixed permanently???

Update: I tried to update handedness with the app, I choose unlock and hit save, the website shows it as being flipped, however if you go back to the lock settings in the app it shows locked (like it defaults to this value regardless of what the lock and server say!!!)…

When I try to save the calibration settings on the web site, I get “A red banner with unable to process request…”… If I try to toggle the lock with the app, I get “Oops, something went wrong!”

These error messages are not actionable information, if there’s nothing I as a user can do to resolve the error, it should probably go into the queue of whomever is supporting the server’s operation, so they can reboot whatever broke on the server side, assuming the problem is there.

Right now my door is open and my Lockitron is seized with the bolt extended and I CANNOT CLOSE MY DOOR…

Also, if the firmware can not complete a locking operation within some reasonable amount of time (say 5 seconds), why does it continue to aimlessly send power to the motor…


#17

@ged we haven’t touched the motor firmware for those units in nearly two years - so no change there. This sounds like a general; degradation of the unit itself (we use on the door here at the office and it’s still doing great).

Is that unit hardwired - if so, at what voltage?

Also, I can’t replicate the error on the Calibrate Settings page. What browser are you trying this in?


#18

@cameron

@ged we haven’t touched the motor firmware for those units in nearly two years - so no change there. This sounds like a general; degradation of the unit itself (we use on the door here at the office and it’s still doing great).

This isn’t a wear and tear issue, the Lockitron has been used a couple of hundred of times. Sense doesn’t work (the bluetooth on this unit does not function at all), so I don’t use it to auto-lock/auto-unlock, I basically use it only when I’m in a rush to leave or I forget to lock up.

Is that unit hardwired - if so, at what voltage?

The unit hardwired to a Nexus USB power adapter (5V 1.8A)… Voltage is between 5.6v when it’s the motor isn’t stressing (.4A) to 4.5v when it’s pulling 1.8A. It is rebooted (1-minute power off), 3 times a day to try to work around frequent random lockups (see bottom) and has a history of doing this forgetting the handedness business (though I originally didn’t understand that was what was happening)…

Also, I can’t replicate the error on the Calibrate Settings page. What browser are you trying this in?

While calibrate settings page now saves, the lockitron doesn’t seem to get as far as calling the mothership to get the settings… using Google Chrome on OSX.

I suspect what is happening is as follows:

  1. Power is lost
  2. Lockitron forgets it’s handedness
  3. Power is applied
  4. Lockitron starts to boot (no network connection yet)
  5. Lockitron is missing a handedness setting so ‘clockwise is locked’, the default, is chosen.
  6. Lockitron sees its no longer fully locked or unlocked (because calibration settings are relative to handedness and handedness has now been flipped), so it attempts to complete either the locking operation or the unlocking operation.
  7. Lockitron gets stuck, it can’t physically move the lock all the way to the locked / unlocked position so it just continues to try squealing the motor.
  8. Goto 6

Even with all the motor squealing, I suspect if I take it apart and reinstall it to the door (manually unseize it), it will go back to functioning normally for a little while until it flips handedness again. I’ll make a video to see if that’s the case.

Random Lockups (recorded last year):


Wake up and forget handedness (recorded last year):


#19

So, this is what happens when I pull the lock ring… plays the little startup song…

@cameron, is the Lockitron you have in the office clockwise or counterclockwise handedness… You’ll never have a problem if it’s clockwise (the default value).


#20

@ged yes, same handedness (lock is on the left side of the door as viewed from the interior). I assume you have tried reprogramming the firmware?