Has anyone gotten Sense to work?


@Craig_Bilodeau when you open the app and explicitly select a Lockitron, will it stay connected for more than a second or quickly flicker off?


Stays connected… At least this time it did. Don’t know about past times.


@Craig_Bilodeau okay, we have some new Sense debugging code in another beta build that will give us some more insight on this. Sense is very dependent on your ability to connect quickly and consistently over Bluetooth, but that doesn’t necessarily sound like the problem here.

We do know that since Sense is tied to significant location change, folks in dense urban areas or up several floors seem to have more trouble.


Just FYI, I don’t live near any tall buildings and GPS works pretty well in my neighborhood. Also my home has it’s own entrance from the outside, on the ground floor, and has no overhang or obstructions for a gps signal. As an example: I have an iOS reminder set to always remind me when I get home and it, without fail, reminds me as I pull up to the driveway.


So, another week, and sense didn’t work once.
Is everyone having trouble with sense or is it just me? Is there another update on the way? Because I’m using the current beta and sense(proximity unlock) isn’t working. I really want this to work. I have a bolt join order, but if that doesn’t work properly,its going back. I can’t keep buying new locks on hope alone. Someone tell me that they got it to work on a regular basis.


@Craig_Bilodeau have you looked into alternatives to Sense? Do you have a Pebble and if so have you tried PebbleLock? I swear by it as an easy way to lock or unlock my door without pulling out my phone (and I built it so I’m biased). Or do you have a Raspberry Pi and desire to learn? You could set it up to respond to web hooks (when ever the door unlocks have it wait two minutes and then unlock or detect when your phone is connected to your home wifi and unlock via Bluetooth). Or if you have a website you can use services like twilio.com or plivio.com to enable you to use Siri to send a text to unlock/lock your door on command.

I too desperately want Sense to work but instead of posting to the forms about it not working I’ve spent my time implementing all the solutions mentioned above to “make Sense work” for me. If you’re interested in trying out one of the above feel free to like this post, or PM me. but all those solutions along with the upcoming Bolt Preview require lots of trial and error, and the desire to not only report problems but also suggest and implement your own solutions to problems. I’m not sure if by “Bolt join” you mean Bolt Preview But expecting the Bolt Preview to work out of the box or else “its going back” is a waste of your money and the Lockitron’s Team’s time and energy. If you’re not willing to contribute helpful feedback like you did initially then I suggest you just monitor the forums for updates and wait for the Production Bolt. Repeatedly posting “is it working yet?” without more information as to when it does/doesn’t work doesn’t help anyone.


I have both a pebble and a couple of raspberry pi. I would love to use one of those pi to control it but both are busy at the moment. One is being used to control my wemo switches because the offical app for them doesn’t work properly either. If you have some info on any work that has been done to use the pi for lockitron, please pass it on. I may re task one of my pi. Which pebble app is yours? I may have tried it already. Also “bolt join” was supposed to read “bolt on” as in I have a bolt on order. Not the preview one, the offical release version.


Also, Hanlon, are you saying that you haven’t gotten sense to work? So, it’s not just me? I’m genuinely asking, because I would like to know if I’m doing something wrong. No one has really replied to the original question. If I’m in the minority and everyone else’s is working, I need to try doing something else.


@Craig_Bilodeau sense is very likely working for a large number of users, but the truth is that we don’t have any hard numbers on this outside of the Lockitron team.

To put into perspective, approx 400 members are registered on this community. That’s total registrations, either active or inactive. When you subtract the number of users who are read only, currently inactive, and who haven’t even posted once, the number becomes far smaller.

Then there are people like myself who post here, but do not have an active unit on hand.

By comparison, Lockitron pushed through approx 10,000-10,500 of the v2/Crowdfunded units. Each one of these is capable of using Sense. Whether they are currently in use, or active is also unknown to us.


Sense works for me but my apartment is so small that when I sit on my couch next to my door it often needlessly connects to the door multiple times every hour and occasionally locks/unlocks thinking I’m coming or going when I’m not.

I made PebbleLock. Feel free to post to the thread about suggestions for feature improvements.

The thread about using a raspberry Pi with Bluetooth can be found here.

The thread about controlling the Lockitron via PHP can be found here. I have since incorporated Plivio.com text messages into this to allow me to ask Siri “Tell Alfred I’m on my way home” which texts a number (Alfred) and triggers a PHP script that both buzzes me into my building and unlocks my door.


@Hanlon hmm, with Sense Proximity Unlock? That’s a bug if it’s connecting like that. I prefer notifications myself which is why I use them instead (they’re ultra consistent for me, although sometimes they take a bit to carry out the command) but I will enable Proximity Unlock and see if I can confirm (cc @Craig_Bilodeau as well).


hanlon, any chance you could port pebble lock to the gear with tizen? ill pay for it too!


So. I seem to have gotten it to work. Sense has worked twice in a row for me. The new beta seems to finally work. Yay!


Here is a progress report. Sense has worked every time I have come home from a 1km or more trip. Good job lockitron teem! It took a while, but you finally got sense to work. Yay!


I hate to revive an old post but I can’t seem to get sense to work. Although I’m not sure for the same reason. When I open up the app, the little map on the bottom almost always says “unknown location” despite having given lockitron access to my location in locations services (iPhone 4s). I calibrated it a few days ago. After which my address was automatically entered into the “street” field but it looked like the next time I used te app it was blank again. My gps works fine in other apps. Am I missing something or is something else the problem. I’ve never got a notification from sense since I set it up a few days ago. Though, I know my Bluetooth works and is syncing with the device from a past airplane mode test


I can’t get Sense to work either on both iOS phones. I’ve set them both to unlock with 500m. Everything has been saved fine. Calibrated settings. Map is showing correctly where I am with the correct address et. I have a very strong and powerful Wi-Fi AC3200 router that covers practically very far. After being gone for hours and walking right beside and standing in front of my door, it doesn’t open up at all. I wait and wait. I open the app and it’s actually connected showing me the state of the Lockitron which is locked.

Anything I’m missing to make it automatically open?


@oneframe I think in the latest versions of the app, Sense is off by default. Do you have proximity turned on like below?

EDIT: Realized you mentioned the map, so you’ve probably done this.

Next step: Is always on location access enabled for Lockitron?

Settings>Privacy>Location Services - ON
Scroll down to Lockitron, tap and make sure “Always” is selected.

Also note - the phone can’t be charging for sense to fire. It will be disabled if charging (like in a car, or from a battery pack).


@anthonylavado, I have everything set except for the location services which is “While using”. I have changed it to “Always” and will let you guys know later tonight which sounds like the fix. TIA.


@oneframe Ah yes, that’ll do it. Without permission to run Location Services in the background, it won’t be able to trigger when you get “close” to your lock.

A previous explanation I posted summarizes it best:

EDIT: Before I forget, make sure this is on too:
Settings>General>Background App Refresh - ON
Scroll down to Lockitron - ON

And the app can’t be force closed on your phone. If you force close it (double click home, swipe up), then it won’t be running until you launch it again.

I should consolidate this now that people are getting Bolt… or perhaps make some small edits to the help document:

@cameron > Is it possible to add a section in the help docs for these settings wrt ios/android? I can provide iOS screenshots if needed.

FAQ Technical Questions - Bolt

Thanks. These documentation really should be spelled out to prevent similar repeated questions when using the iOS app. I will report later.