Troubleshooting Lockitron Bridge


#1

I think it would be a good idea to have a separate topic to discuss issues related to the Lockitron Bridge (as opposed to including it in the Bolt Preview topic).

I can’t seem to get mine to work either. I was able to BlinkUp successfully using the Lockitron iOS app (I ran into the same minor issue where it creates a new Lockitron after BlinkUp that @nfarina mentioned and @cameron is now aware of)

But even when the Bridge is 1-2 feet away from my Lockitron and connected to Wifi it still doesn’t relay commands to the Lockitron sent via the web Dashboard or iOS app. The Bridge itself doesn’t seem to be advertising BLE services as it’s not showing up in my Bluetooth scanner app LightBlue. Is it suppose to be advertising?


FAQ Technical Questions - Bolt
#2

@Hanlon good idea, thanks for creating.

The Bridge itself doesn’t advertise - I suspect most of the trouble that we’re seeing is due to range.

We’re working on adding information to the web dashboard to indicate if Bolt is “online” or “offline” based on a nearby Bridge. This data is already being relayed via the API (take a look for the “connected” flag while making a request against the lock endpoint in the dashboard).

1-2’ might be too far given the antenna situation - if you can send me the Imp MAC address on your Bridge I can pull up the logs to see if it sees Lockitron. I should also note that it will eagerly scan for and select any crowdfunded Lockitron as well. At the moment we have to power down the crowdfunded Lockitrons in our office to ensure that Bridge connects to Bolt as their Bluetooth gain is far better. Bridge is set up to automatically select the strongest signal strength Lockitron it sees on boot - power cycling it resets this selection.


#3

Is there a way to test/troubleshoot the Bridge?

I was able to perform BlinkUp successfully (via green LEDs) and was able to confirm that it connected to my Wifi (it’s listed as a connected device on my router) and @cameron was able to confirm that it can connect to my Lockitronv2 via the MAC address I sent him and it seems to successfully receive commands sent over Wifi (it blinks blue) but I can’t seem to successfully execute commands to either the Lockitronv2 or the Bolt Preview sent through the bridge. Maybe there’s a way to serially connect into the Bridge? Intercept packets sent by the Bridge?


#4

@Hanlon hmm. Unfortunately not, there is a Bluetooth header but that’s only for programming - all the imp stuff is locked down. I will see if we can expose more of what we see server side here - I’m thinking listing connected Bridges on the Settings page for a given lock.


#5

I’ve had some issues using Bridge altogether here. I’ve been able to successfully BlinkUp the bridge to get it to connect, but I only ever seen the blinking green light, and nothing else. It never goes to a solid green, and I don’t see a blue blink when interacting with it.

I do know it’s connected to my Crowdfunded Lockitron as I no longer get a connection from my iPhone over Bluetooth to the lock.

I have it at my front door closet, and there shouldn’t be any Wi-Fi range issues. The Crowdfunded unit happily connects to Wi-Fi when I operate it, and I also have a Wink Hub in there as well, working without any issues.

I’ll try moving it further upstairs and see if anything happens.

As a side note about range: I can connect to the Crowdfunded Lockitron’s Bluetooth from my room on the third floor. The signal is very strong!


#6

@anthonylavado I have the exact same results as everything you said (successful BlinkUp, successful connection to Bolt via Bluetooth on the iPhone app, and unsuccessful connection to the crowdfunded Lockitron while the Bridge is on), except for the Bridge never blinking blue. For that you should try removing the batteries from your crowdfunded Lockitron and then unplug and plug in the Bridge with it right next to the Bolt. From there lock/unlock commands I send from the Lockitron.com website to the Bolt make the Bridge blink blue. Although the command times out and never actually executes on the Bolt.


#7

Update here: we’re working on fixing some Bridge issues, but if you have an iPhone I recommend powering it down for now as it significantly impacts the reliability of Bolt at the moment (and the iPhone app isn’t very sophisticated about selected whether to control the lock over Bluetooth or WiFi at the moment).


#8

Any word on Bridge so far?


#9

@anthonylavado we’ve made a couple of improvements but I’m currently working with support from one of the real time messaging companies that we’re using on the backend.

The key issue here is the iOS app - it can “block” to from using Bluetooth if it thinks that you have a web connection, and in turn send the command via web + Bridge which is less reliable (and creates a more frustrating experience). We’re working on a strategy now for the app.

So, I would say that you can give Bridge a try but if you have issues, put your phone into airplane mode with Bluetooth on to control Lockitron directly.


#10

Hi folks - a quick update here:

We’re now working through a couple of critical bugs that cause a lot of inconsistency with Bridge. We have a few small initial changes to help Bridge fail more obviously so we can isolate the failures and knock them down one by one. I’ll be following up as changes are deployed (everything with Bridge is OTA and doesn’t require intervention by you).


#11

Just following up here: is there anything I have to do to get my preview Bridge to see the “updated” preview Bolt?


#12

@anthonylavado big changes on Bridge. I think you might be on the “development” branch, so it won’t work for a little while here, sorry about that.


#13

Hey, just curious, will bridge support both 2.4 and 5ghz?


#14

@Jason_Silva no, sorry, just 2.4ghz.


#15

Hey there,

I just installed my bolt and ATTEMPTED to get bridge running correctly. It is very rare that the lock responds to commands over wifi and outside of my network I cannot view the status of the lock. I think there should be some clarification with the meaning of the blue/green flashing combo as that is not listed in the documentation to my knowledge. Just want to get it up and running!


#16

@GrahamWerle could you let me know what the RSSI numbers are on the Bridge Diagnostics page? This is under the Settings tab. It’s likely Bridge is having trouble connecting to either your WiFi or to Bolt.