Lockitron Community

Android: Notifications have stopped working


#1

I use Android. I recently have stopped receiving notifications from Lockitron. (Except for the annoying persistent “Do you have android wear?” notification.

I have app version 3.5.15. In the app settings I have Lock notifications: Always, User Notifications: always, Lock reminder: On.

In Android Settings, under “App Notifications” I have it set to “On”, Allow notification dot “on” and under Categories I have “Wearable service”: on. Under “App Permissions” I have contacts, location and storage all on.

(I want “wearable service” off because I don’t have an android wear device, but wanted to turn everything on for this test.)

I’m running on a Google Pixel 2 XL running Android 8.1 with security patch level June 5, 2018.

When another lockitron user locks or unlocks the Bolt, I get no notification. I have rebooted and tried again with the same result.

The Bolt has firmware version 1496963301. I get the same result using Bridge or Bluetooth.

Suggestions?


#2

I rarely use my lockitron, so I can’t comment on if notifications have stopped working or not.

I just wanted to chime in and say that the persistant notification for “Do you have android wear?” needs to go.
I have enough things taking up space in my notification bar. I don’t need a notification constantly asking if I have Android wear, I don’t, now let me swipe your message away.


#3

@jjd @Bob looking into this.


#4

Thanks a lot, @cameron.


#5

Thank you.

Looking at the Google Play reviews, others are having the same issue.


#6

Thanks for the quick fix. It is gone now.


#7

I just want to be clear:

I downloaded the new version (v 3.5.16) and it does indeed fix the “Do you have android wear?” persistent notification, but it does not fix the problem of not receiving other notifications from Lockitron (like lock/unlock events).


#8

Just an update: Tested notifications on both my Pixel XL 2 phone and my Pixel C tablet and notifications don’t work on either. Both running Android 8.1.


#9

Any update on the Android notification problem? Thanks.


#10

@jjd can you pin point how recent this problem cropped up? Was it due to the broken app update?


#11

I can’t be sure when it started. My best guess is that it was around the beginning of June or the end of May. I’m sure it wasn’t working whlie I was away on a trip the week of 4 June.

If it had anything to do with a bad update, it should be fixed with an app uninstall/reinstall. I will try that.

Having some experience with this type of problem, another thing you should check is the security certificates on your back end server. If any of them that are used for notifications at google have expired or the keys used to sign them have expired, that could cause the problem too.

I’m having the problem on three different android devices available to me. Are there Android users out there for whom notifications are working?