Lockitron Community

App crash after update?


#1

Hello, today (GMT +1) I updated the lockitron app,. When I opened it the app was unable to send commands, pressing the list of lockitrons and there where 0 lockitrons and the app crashed

Good news, you can delete the lockitron app, then reinstall it and log in. It worked for me

Should just mention it just in case someone else have the same problem

If you do not want to reinstall it, you can log out before updating


iOS App 2.3.0 - Release Notes
#2

@TrulsZK thanks for noting - we’re hearing this from some folks and my guess is that there was a shift in our data store and that you need to remove/reinstall to solve this.


#3

Had the same problem after updating to the latest iOS Lockitron app. Followed TrulsZk advice and it worked. Have yet to try Sense beta though.


#4

Hey, I sent a support request message in a week and a half ago and have not seen any reply. My app crashes persistently. It has been unusable for months and after a while I gave up on it, so the device just sat there as nothing more than a clunky deadbolt knob (crowd funded). Honestly, even though I had the newest version of lockitron, I figured it was my fault, as I was still sitting at version 7.2 or something like that (I’ve been burned by iOS updates in the past).

Anyway, after I started seeing similar crashes with other apps, such as youtube, I decided to break down and update to the newest iOS. Well, it fixed the other apps from crashing but not lockitron.

I’ve tried turning it off and on. I’ve tried soft resetting it. I’ve tried deleting it and redownloading it on the device. I’ve tried deleting it and redownloading it from itunes on my desktop. Nothing works.

When it loads up, the background screen is flashing blue and black. Then without touching it, it goes into the “asleep” screen with a "your command will go through… " wakeup time several hours away. The last time I tried it, it had a wakeup time of about 24 hours. I thought I had issues with it going straight the command will go through page before and a firmware or app update fixed it, but its back. Anyway, I digress… as soon as I push cancel to get back to the control screen, it does so and the blue flashing stops. Okay great. Except as soon as I then try to enter a command, the blue flashing comes back, along with the asleep page. After about 10 seconds it crashes to my desktop. Any subsequent attempt so reopen the app and it crashes. Scratch that, I’m now noticing that it only crashes when I’m near the device w/ my phone. So if I walk within, 15-20 feet of it, it’s no mas. Of course, walking near it is how I knock on the door to wake it up and ensure the command went through. So maybe a problem with sense? I’ve never gotten it to work with sense, which is really unfortunate, because that was a big draw for me back with kickstarter.

Anyway, how can I fix this ? Thanks much


#5

The app is working fine for me.
Tried another device?
Tried to reflash firmware?

You may also completely erase the phone and set up as a new device (Not the backup, if so you may restore the issue)

You have the newest version on everything (Lockitron, app, phone, etc)

Does the dashboard on lockitron.com work?


#6

@sean2a - A couple of quick notes

The Lockitron App Store update notes say that uninstalling it and reinstalling should clear that. If you’re still having issues (which you say you are), then logging out and logging back in are the next steps.

As for Sense, you do need to be running at least iOS 8.1.2 for it to be working reliably/at it’s best. Always make a backup first, then update whenever one is available.

If you’re having issues with Sense, make sure you’re on the latest firmware from your Lockitron dashboard.
You can check it under settings. It should be the version ending in 9060:

If the firmware hasn’t updated, or it’s still not working, you may need to follow these steps:

  1. Reflash Bluetooth
  2. Pull battery, wait 60s, insert
  3. Reflash firmware
  4. Pull battery, wait 60s, insert

If you’re still having trouble, let us know and good folks like @TrulsZK and I will help :slight_smile:

Edit: I just re-read part of your post- Having the wake up time be in 24hours is a sign you have Power Save enabled. That means the Wi-Fi remote access only wakes up when you either open/close door, or knock on it. Bluetooth is always immediate access, so make sure you have it turned on. If the app connects by Bluetooth, you’ll see a Bluetooth symbol in the lower right hand corner.


#7

Yeah, as I’ve realized, the app does work, it only crashes if I’m near the door. So if I put a command in far from the door and it’s pending, I can go to the door, knock and it opens. It only has issues if I try using the app near the door. I should note, that, even when I was only trying to watch the setup tutorial, when I got close it crashed.

I’m currently running iOS 8.3 on an iphone 4s. I’m also confident I’m using the newest version of lockitron as it does not appear in the app store under updates. I’ve checked the dashboard and I am using the firmware ending in 9060. I have noticed if I disable the bluetooth on my phone and try the app near the door, it works fine. I just put a request in to “reflash” my bluetooth.