Lockitron Community

Bolt Beta Firmware


I think I’m having unlocking issues. Could I try the Beta?



@ConnectedHome you’re marked for the beta :slight_smile:



@cameron - I’d like to try the firmware beta.



@cameron how often is the beta firmware updated?



@JPeterman added!

@Beavis97 infrequently; we strive for long lived stable firmware builds because the update process is slow and there are a lot of risks to changing the firmware.


Bolt+bridge: bogus activity updates and battery

no idea if this is a bug due to software or due to the beta firmware but ive had a problem with sense these last 2 weeks that i find very strange. its happened 3 times so far. Where i go home to the door and i feel my phone vibrate which usually signifies sense unlocked. but instead of saying “unlock succeeded” it says “locked succeeded” … no idea how and why… i dont hear the lock do anything, it doesnt unlock, it stays locked and when i use a key to manually unlock the door, my phone automatically vibrates again and then it says “unlock succeeded” i tried taking a screenshot but because i unlock my door, the normal message overlaps it. very strange… am i the only one to experience this bug?



ok, im not sure but now its happening almost every time.



@Jason_Silva that sounds like it could be low battery; do you hear three beeps when locking and unlocking?



nope, no beeps…



@Jason_Silva only Sense; any trouble with Bridge or directly with the app in the foreground?



nope, not that i could tell. battery life on the app also states 96%, not sure how accurate that is though…



@Jason_Silva thanks. Sounds like an Android specific Sense bug we need to look into. My guess is that it fails to send the lock command, but then remains connected - then it see’s the lock and unlock events while it believes it’s carrying out the Sense command.



@cameron I’d like to give the beta firmware a try.



@klidec you are now enabled for beta!



Thanks. So far for me the change to this beta firmware has been Extremely positive. Only been running for about 24 hours but can already see the difference. I have three people with access as well as a bridge.
Usually my wife’s phone would “hog” the connection. I would not be able to access the lock state and connect while at home with my wife at home 90% of the time. Also when checking status remotely I would more often than not be unable to check status and connect remotely.

After: I’ve had no issues attempting to connect. Came home today with two users at home and I was able to open my door no problem. Been checking status remotely through out the day with no issue.
I don’t want to be overly optimistic here but I can at least say this is going in the right direction.

I’ll report back if I run into any problems.

1 Like


@cameron all my issues related to multiple users that impacted users being able to access the lock or to check status remotely appear to be resolved. Which is great!

Should this firmare also fix the battery indicator % read out? Mine still shows low which after only about 1 month off usage I don’t think should be the case.



@klidec that’s great to hear; I’ll have to review the release notes to see how the connection handling could have been improved as I believe that the Sense timeout might still create issues .

Battery reporting seems to be broken across a few versions pointing to a web issue that I’ll look into.



I’m not too concerned yet with the battery status.
As long as I can hear the beep warning from the lock I’m fine for now.
I’m really happy right now with my lack of connection problems. Perhaps there is still an issue related to sense Timeout that might create an issue but I went from rarely being able to connect when other authorized users were home to not having any issues since the new firmware.
The only way I could reliable connect to my lock before was to turn off Bluetooth on my wife’s phone and then I could connect. You actually helped me troubleshoot an issue where my mother in law was hogging the bt connection and my wife and I could both not connect. You suggested I disable bt on all users and then turn them back on as a temp “fix” for the issue.
Looking forward to seeing this product evolve once you get the fundamentals rock solid. Especiallly user access features (schedules, local only access etc…)

1 Like


@cameron wanted to report back on the single issue that I’ve experienced so far with the beta.
The other day I came home and was not able to unlock the door with the app.
Everything appeared as though I was connected. I could see the lock/unlock buttons. But clicking unlock would not do anything.
FYI: I have the bridge. I have sense with notifications enabled.
I proceeded to go into my house via the garage. Went upstairs to my lockitron lock and I was then able to open and close the lock.
So the issue didn’t last long. I’m Still in a much better situation with the beta firmware than I was prior to it.



@klidec hmm, were you able to lock inside simply due to proximity? Or did you turn it first by hand?