Lockitron Community

Bolt Beta Firmware


@cameron I don’t believe it moved partially. I’ll pay more attention to it if it happens again. Perhaps i didn’t wait long enough on app open? Buttons were solid colors when i pressed them though.



@klidec ok, good. What you’re describing sounds like the buttons weren’t yet ready to pick up touch events when you tapped vs. a mechanical or firmware issue (or that the app sent the request via WiFi first, then connected to Bluetooth blocking the command).

While I think I’ve noticed this I will need to test; there is some give and take on our end to show the buttons quickly vs. hiding them until we can 100% guarantee a command will go through. We did have some fixes to help with this scenario (WiFi then Bluetooth) but it seems like they aren’t 100%.



Can You please include me on the beta access for my Lock







@sdlockguy not sure if I mentioned via email, but you’re marked for beta.

@Jason_Silva thanks; I think our background Bluetooth behavior on iOS and Android is being a bit too aggressive in the scenario where it fails and you carry out another command. We’re looking into it.



@cameron I would like to be in the beta, please.
Thank you!



Can I get the betaddressee firmware



Would like to try the Beta firmware myself



@cameron how close are you to moving out of beta and into GA?
I also se the app had been updated a couple of times recently. What were some of the bugs that were fixed?



@klidec soon; we’ve reached an impasse with a code size issue so we need to slim a few things down and push out an additional beta before the general release.

On the iOS side we’ve recently fixed the following (all these fixes should be in production):

  • Prevent random activity creation when loading the Widget
  • Fix a server-app key syncing issue
  • Improve BlinkUp



Checking on any latest Bolt Firmware release, fixes, and ETA? Thanks.



@oneframe we’ve release another few beta updates. We’re working to move it into production within a week or two. We ran into size issues with updating the firmware over the air and are currently slimming down.



Okay, thanks. Maybe there can be a thread that updates whenever there is a new firmware version whether beta or final release and what has changed so we can compare to what we currently have.

Also on the app it would be good to state this as well. What’s the latest version and what do we have. The app doesn’t show anything except our current version and the ability to download a firmware. Unless I’m missing something.



@oneframe sure; we do have a beta firmware thread but it might be closed, haven’t updated that in a while.

One production builds of firmware a couple things will happen: we will notify you via email when a new build is ready as well as via push if you have system notifications enabled.



Cool. Can we revive that beta firmware thread then and update what the latest versions are and what to expect from each. It’s a good record and refresher on us testers. Thanks.



@oneframe merging your topic here to revive the thread.

We have a couple of features that are now [buggily] available - Auto Lock and Power Mode. I say “buggily” since we don’t give you a good indication of when or if these settings have synced with the lock.

We’re working on an update for Bridge that we’re testing internally which would set these instantly, however, that will take a bit more time.

To test, head to the “Settings” tab in the web dashboard and set to your preferred level. More data on Power Mode to come, but we’re pretty excited about it here.

This includes all the prior fixes from the beta as well as a new watchdog timer to help in cases where the lock seems to crash.

Anyone on the beta will get this update if they carry out a firmware update; the version is (currently) 1492716648. This is intended as a release candidate, so please send any feedback.

1 Like



@cameron, went to the web dashboard and applied the auto lock after 10 seconds. Nothing happens to my lock. I have the current version you stated above. FYI.



I can only get it to lock with a 5s delay. all other options do not work (I’m on the latest Beta, using an iPhone 7. I have tried everything to activate longer delays (cycling power or both bridge and bolt, restarting bridge, logging in and out of the Dashboard site, etc…).



I have tried 5s and confirm that’s the only setting that works. Although that is too short especially when you have more than 1 person exiting the door. You’re about to close the door and it start to lock already.

I amended it to 30s and hope this will work one day.



@blondscott @oneframe thanks - I’m working on another area at the moment but will look into this bug (it’s web related, not lock).