Lockitron Community

Bolt Firmware Update 1496963301 - Release Notes


After extensive testing and improvements, we’ve just released version 1496963301 of the Bolt firmware. This firmware is a mega release and has a number of improvements and introduces some new features into beta:

  • Fixes bug where users needed to tap unlock twice on some doors to fully withdraw the Bolt
  • Fixes bug in battery percentage reporting that would return impossible values (i.e. 140%)
  • Improves timeouts in cases where one device was staying connected for too long to Bolt
  • Resolves certain cases where the device would crash until a battery was removed and replaced

Additional features (largely in beta due to pending client updates and web updates):

  • Adds support for Keypad
  • Adds beta support for auto-unlocking (note: due to syncing issues in the apps, it may take several attempts to enable or disable this feature; it can be found in the web dashboard)
  • Adds alpha support for returning logs from the device for offline events (i.e. when the lock was turned by hand or key)
  • Adds beta support for changing the power mode of the device to optimize it for different scenarios including longer battery life, improved Sense connectivity (in some scenarios) or optimal Bridge connectivity

The good news is that while these additional features are “beta” in due to lagging client support, you won’t need to update the lock again in order to take advantage of them as we update the clients and web server.


Just updated. My battery level says 0% when before I updated it was in the 40’s. Lock seems to be working just fine. So what could be the problem?


@Nadforever how many months have you had them in? It’s possible it’s a spurious reading, but the update has more protections to prevent that. Maybe app didn’t sync correctly until the update.


Just updated when the iOS prompted.
My firmware shows 1461012547 different than what you mention above.
Clicking on upgrade firmware said I’m already on the latest… hmmmmm


@Eggyacid opt to continue past that message. The logic that checks to see if you’re on the latest build can be a bit slow to update.


Been testing out the new firmware and got some problems. I selected 5 seconds for the auto lock, and it worked fine but wasn’t enough time. I raised it to 15 and it worked but still wasn’t enough. I raised it to to 2 minutes and it stayed at 15 seconds so I raised it to 5 minutes hoping that would fix it. Now after an unlock the lock does the countdown beeping like it’s going to lock, but after 10 seconds or so it just stops and stays unlocked

Also sense is still really hit or miss


Just went through all time options one by one with a stopwatch. All worked except for 5 minutes. It stops beeping after 45 seconds and stays unlocked


I waited the full 5 minutes to see if it would still lock and had just stopped beeping but nothing.
I went back down to 2 minutes and that worked fine again.

Oh, you can edit posts.
Also, my battery level is listed at 0% also


@Omar_Cataldo syncing issues in the apps mean that the timer won’t always be set immediately leading to the discrepancy. I’ll check on the 5 minute timer.

How long have you had those batteries for?


Can confirm, times greater than 2+ minutes (or technically 255 seconds) will fail.

Fixed this issue in our codebase. Will push it to the beta build shortly. New upper limit is ~18 hours.

Thanks for spotting this.


I’ve been ignoring the “Battery level: 0%” message for months [Firmware version: 1496963301]. Today my crowd funded Bolt failed to complete the lock operation. What was interesting was that the physical latch/bolt (the part that moves in/out of the lock mechanism) would no longer fully retract. Even after manually lock/unlocking, when unlocked the bolt would protrude by 0.25 inches from the latch mechanism. After removal, each of the 4 old batteries measured 1.2v. Replaced with new batteries each measuring 1.58v. Using App with new batteries installed, to lock/unlock, the “protruding” bolt reset itself. Lock now works normally by App or manually.

However “Battery level” still shows “0%”. [Firmware version: 1496963301].
Bolt/Bridge has been in operation for two years. This is only the second time that I have replaced the batteries.
(Installed July 2016, batteries replaced July 2017 and again July 2018)


@Dave we are very conservative on battery warnings since some doors require a bit more torque to lock/unlock. That said, impressed you got a year out of them.

The 0% indicator can take several connections to update to the new battery percentage. Again, due to conservatism you likely won’t see 100% but something in the high 90s.


My battery % level only ever worked on my first set of batteries. it has said 0% since the very first time I changed batteries. The more important question is when will we be receiving our bridges?


Cameron: As you predicted Battery Status changed from 0% to 88% today (3 days elapsed). I was skeptical but glad to see it working. :wink:



What about the “mechanical failure” of the “bolt” protruding by 0.25 inches in the unlocked position? I could not get it to reset properly by locking/unlocking manually. Reset to normal unlocked extension did not occur until I replaced the batteries and performed an App based lock/unlock sequence.


@Dave that’s due to low battery and why our idea of 0% is higher than the ability of the lock to drive the latch part way.


I don’t mean to beat a dead horse and I do appreciate the responses so far, but just to be crystal clear:
It is possible for a battery failure to leave the bolt in a partially extended state that cannot be fully reset by a manually unlock. Therefore, it is best practice to replace the batteries prior to such a failure.

As I mentioned I’ve had the lock run for months at “0%”. I’ve gotten 1 year of operation from a set of batteries. Since I’m cheap, I test the batteries before replacing them. My new procedure will be to check the batteries at the beginning of the 12th month. If I find any have less than 1.25v I’ll replace the full set. If not, I’ll roll the dice for another month :wink:


@Dave it’s possible that below the reported “0%” threshold unexpected stuff can happen, i.e. all bets are off :slight_smile: Above 0%, if you see this behavior, then you might have a faulty latch or a poorly drilled door prep.

In any scenario you should be able to use a key to manually unlock; if you have trouble with a key manually unlocking then there is an installation problem or the latch may be failing.

1.25v is amazingly low to keep going. I think to be extra safe our low battery cut off is well above that!


@cameron I’ve been trying to get in touch with support@lockitron.com and it has been crickets. I’ve been trying to get an update from support in the last month (for a support ticket that’s been opened for more than a year now). Any chance you can help take a look? This has been related to trying to get the firmware updated on my bolt.