Lockitron Community

Crowdfunded Firmware Update 1418069060 - Release Notes


We’ve just pushed a minor firmware release, 1418069060. This means we aren’t automatically updating everyone to this release just yet. Please note - while this is a minor release, if you’re still running on the last stable major release, 1411004335, we highly recommend that you update to the latest release. There were significant updates in 1411693751 and 1418069060. This release includes everything from 751 as well as the following:

  • Fix for battery voltage not being reported correctly which could result in missed low battery
  • Improvements for Bluetooth connectivity with Sense
  • Fixes for updates which could become “stuck” (although you might still get “stuck” in this update from the old firmware, so keep an eye on the update progress via the % indicators on the Settings page in your web dashboard)

Some might note the older timestamp on this one - we’ve internally been testing builds of this firmware for a while (although some changes on the Bluetooth side were done and verified more recently).


No response from support
No low battery warning - ever
App crash after update?

“We’ve just pushed a minor firmware release, 1418069060. This means we aren’t automatically updating everyone to this release just yet.”

As my lockitron is still running 1411693751 according to my dashboard. I have reflashed the firmware and no update to what is above. What is the timeframe for making this latest build available?



Okay after it refreshed to the same old firmware, it started to download the latest build. Now the odd thing is that it was reporting a battery voltage of 6.0V, after it updated to the latest build it now is reporting a battery voltage of 5.6V. Any idea why the discrepancy of the voltage from one build to another?



Ther firmware basically “killed” the Wi-Fi indicator light on the lockitron making me believe it isn’t connecting to my router at all. However, refreshing my dashboard page shows that it is in fact connecting and reporting the lock unlock status and corresponding timestamp. I lock and unlock the lockitron once more and no Wi-Fi indicator lamp.

Are you guys aware of this issue and what is your plan in addressing this bug on the latest firmware?



@oneframe okay, a few things - the voltage discrepancy is the voltage fix. The reason why low battery wasn’t reported for some folks is because voltage wasn’t ticking down as it should now it does.

Our firmware has no ability to impact the functionality of the WiFi LED whatsoever. That’s entirely handled by the Electric Imp firmware which is out of our hands (and should not have changed for you). Does it light up when you remove and replace a battery? I can check with the Electric Imp folks to see if they’ve ever seen anything like this.



The battery is new. It’s the new duralock copper core. I checked the capacity and its 2/3 full. The wifi light worked after I removed and reinserted. Prior to that “reset” it didn’t light up after the firmware update.



I’m getting low voltage warnings after a couple days since installing the new firmware. I’ve been using fully charged Eneloop’s and changing them once a month. Never had a problem until now. Is it possible the firmware is reporting too early or draining the battery faster?



@Michael would you mind trying a couple things? A lot of battery drain issues seem to crop up around firmware updates, and reprogramming (again) can sometimes help. If you don’t mind, since you have Eneloops (and can recharge), can you try the following

  1. Reprogram the firmware again

If that doesn’t help:

  1. Reprogram the Bluetooth firmware
  2. Reprogram the main firmware

Also, how many cycles have those Eneloops been through?



Noticed with the latest firmware (either it’s the firmware or coincidental with your server) the Activity reporting on the lock hasn’t been consistent at all.

For example when I left the house this morning to hit the gym, it shows that I unlocked the door at 6:27am and doesn’t report that I locked it immediately. The next lock was when I got back home from the gym at 7:40am. It doesn’t report the state of unlock and then lock.

When this first occurred, I thought I simply forgot to lock my door after leaving the house which is not the case because I tested it right there and then to unlock then lock, but only one or neither was being reported. This is despite the green Wi-Fi connection status both times which means it’s connected to my router.

For the sake of Activity reporting, I unlocked and then locked two times before writing this. None of these have showed up. This was unlike the previous Lockitron reporting which was instantaneous. Notice from my screen shot that last Activity reporting was 11:38am. No reporting of any unlock/lock at anything past 12pm which I did twice and refreshed the page multiple times.

I have not changed anything from my Wi-Fi set up.

Look at the pattern of the unlock and lock and you will see that it seems the door was not locked until after an hour or so later which is impossible.

Cameron, are you aware of this issue? If so, what is your plan to fix this?

This is dangerous erratic reporting especially for my insurance company to use against me. They will think should there be any break-in to occur that the house simply was not locked.



@oneframe we haven’t seen this on other locks. Can you re-program the firmware and see if it helps? This type of behavior seems to typically be tied to WiFi problems rather than anything firmware related, but we’ll take a look.



I have been having the exact same issue.



@cameron Re-flashed firmware I believe 3 times the last time. Re-flashed again today as requested.

As experienced prior, the Wi-Fi signal and light indicator dies completely after re-flash. Had to remove the battery to bring it back alive.

After this latest re-flash, I unlocked then locked. No reporting on my Activity log.

Also prior you will see that when I left the house at 4:03pm, I made sure to lock the door. No reporting of it being locked.

When I went home by 6:29pm, it shows I never unlocked it. Only shows that I locked it which is an 1.5 hours later which makes my insurance believe I never locked my door.

In line with this odd reporting behavior, the last two logs you will see that I locked it by hand on 6:31pm and then another lock by hand on 6:32pm and no unlock in between which is IMPOSSIBLE.

See attached.



As you can see I’m not the only one experiencing the same, exact issue. Also if there are Wi-Fi problems on our end there should be a Wi-Fi disconnect Activity reporting as before.



This is one of the major issues I have with my Lockitron. I find that basically any feature that relies on wifi is not reliable.



@oneframe to clarify one bit which I see you mentioned from above but never addressed here - the WiFi LED indicator has always turned off after a set period despite the fact that your Lockitron may remain connected to WiFi.

Thus the indicator is only a good indication that the device did in fact connect, not that it is connected. This is electric imp behavior that’s out of our hands which is why we typically ask folks to remove and replace a battery to fully verify that the device can connect. Based on your description, I don’t see that there has been any change in this behavior. If the device needs to have a battery removed and replaced before it responds to any button presses, this is a firmware update issue but not related to the WiFi LED.

Could you:

  • toggle the “handedness” setting via web
  • hit save
  • remove and replace a battery
  • toggle it back to the correct setting and save

Was there any other event just before 4:03pm? I.e. did you unlock first, before leaving, then lock the door?



I reprogrammed both the Bluetooth and main firmware and installed a fully charged set of Eneloops. The initial voltage reading was 5.4v. After 24 hours, the voltage reading is 5.2v, but I think this is closer to what I would expect. These Eneloops have maybe 20 recharge cycles on them. It will likely take a few days to see if this solved the issue.



@cameron okay so the work-around of playing with the handedness settings as you suggested seems to have fixed the reporting issue. Prior to this the reporting has been getting worse today as you can see in my screenshot. I know for a fact that the Nanny left the house and locked the door at 3PM. My wife and kids also left the house around 5:50PM. None of those activities were reported except when I came home at 6:52PM.

After your work-around suggestion, playing with the lock/unlock has now started to report the activities once again.

Can a later firmware fix this issue than the above work-around? Do you know what is causing this erratic reporting and why the handedness has setting is the fix?



@oneframe setting handedness shouldn’t be a temporary workaround, but rather a fix for it. We’ve seen memory corruption occur during the update process which can cause the handedness bit to get reset. Very frustrating, and related to the broader memory structure (not this specific update). Please let me know if it seems to revert back to the previous problems.



It’s back and not in sync again. Like I said, the above it just a work around. It needs a real fix.



@oneframe we aren’t seeing this “swap” on other units, my guess is that the memory is corrupting on that unit. We can arrange an RMA - PM me for more details.