Lockitron Community

Crowdfunded Lockitron won't connect


I have the crowd funded lockitron. The batteries died quite some time ago, and I never bothered replacing them. Now I want to use it again, and have replaced batteries, except now it won’t work. It simply won’t connect to wifi and when I try to use the set up new lockitron steps, it tells me my serial number is invalid. Currently, I have gotten it to the flashing orange light after removing battery and replacing and then blink up. However, I am stuck as to what to do next. HELP!


Hey there! I don’t work for Lockitron, but I’ll help as best I can.

Sounds like there’s a few things going on, least of which is pending Firmware Updates.

When the Lockitron was initially registered, the serial number would have been bound to that account, meaning it can’t be registered again. The only way to register it again is to remove it from an account.

  • If you’re using the same e-mail that you initially registered with, you might have to unregister the other entry.

  • If you’re using a different e-mail, see if you can reset your password on the original account.

  • Failing all that, support@lockitron.com can help remove it for you (with proof of ownership).

Once you do get it to clear, then you can go into the app, bring up the menu, and choose “Support”. There should be an option to “Clear WiFi Settings”, and this will start a BlinkUp sequence that “resets” the Lockitron.

After you successfully clear it, you should be able to register and proceed.

Be aware that once you get it linked, it’ll spend some time to update both Firmware and Bluetooth chips until it’s back up to a running state. You can check on the status through the app, or through the Lockitron.com dashboard, under Settings.

If it gets stuck for a long period of time, you can also use the Web dashboard to push them through again. You may need a quick battery pull to restart the firmware process if this happens. If you do have to push manually, I believe it’s AVR Firmware first, then Bluetooth.

Used Crowdfunded Lockitron
OTB crowdfunded Lockitron not being recognized

@Naytdeets the suggestions @anthonylavado are very good; if you can’t get past the serial screen, enter “talented cafe 41” to continue at which point you can BlinkUp a device that has been offline for a while. Then once it’s online you should be able to re-start set up with the original serial number.

Used Crowdfunded Lockitron

Hi guys,
Thank you for your suggesitons… I bought a used crowdfunded lockitron. I can’t seem to get it working. I got to the point where you need to blinkup to get it online. It errors out. Please see attached print screens.

I’d appreciate any help. Thanks


@bli3z can you try this via the Setup New Lockitron dialog rather than the Support page?


Hi Cameron,
I surely can, please provide the link


@bli3z no, this is in the app - “New Lockitron”


That’s what I did. I clicked on New Lockitron, entered serial number (under QR code), then it fails to connect to wifi, see error messages above…


@bli3z are you attempting to connect to a 5ghz WiFi network? Does the LED turn green after BlinkUp or continue to flash red?

The video at http://help.lockitron.com/article/59-connecting-lockitron-to-your-wifi-network has the most comprehensive visual aid on what I’m describing with the LED.


Connection to wifi can be troublesome. In my case, the Crowdfunded Lockitron connects the standard 48 times a day to the internet, which completely drains its batteries in 1 to 2 days even if the lock is only used manually. Is there some command that the folks at Lockitron could issue to resolve this issue (i.e. make it so there is only 1 internet connection a day)? I ask this because I’m not a programmer by any stretch of the imagination…


@Nick to be a bit more specific, it’s draining because one of the micro controllers is staying awake keeping the WiFi on. Checking on the Bluetooth key.


Thanks very much Cameron! I do appreciate all your help! I don’t mean to seem bothersome, and will wait to hear from you.


@Nick finally got the Bluetooth key; you should reprogram the Bluetooth on your unit followed by the main firmware. This can be done via the Settings page of the web dashboard (you can’t do it via the mobile app).


Thanks my “boss” will be much happier. She is particular and hard to please. :thumbsup:


I keep getting invalid serial number on IOS and Android

Is exactly what I did to cause the problem all I did was replace the batteries and tried to send an invite and it kept telling me something went wrong so I decided to reset it up to see if that would fix the problem


I’m also having this issue in ‘timing out’, having picked up an original Lockitron while I’m waiting for my Bolt’s Bridge to arrive, as well as a Weiser keyway - why not? :slight_smile:

I’ve managed to get the Lockitron online to my 2.4ghz Wifi network, insofar as I cleared the wifi info using the app’s Support page, then after 20 or so attempts, Blinkup finally worked: the Wifi icon is blinking green, though I’m flummoxed as to what IP it’s grabbed as I have to eliminate the non-named devices on my router one by one. Maybe tomorrow.

What’s going on is: the app looks for the Lockitron, but times out every attempt. I’ve got the Android phone on the same 2.4ghz network, just in case, but it’s like they can’t see each other.

Am I right, in that the original owner needs to ‘release’ the S/N from their Lockitron.com account online? They’ve already done it in their app, which was great, but I’m stuck…

Any help would be appreciated!


Update: I’ve managed to get the wifi connected to my 2.4ghz network, as far as I can tell. The Blinkup code is alternating green, and an unnamed device is consistently showing up at the same IP on my secured network when I power up the Lockitron and refresh my Netgear 6300’s Attasched Devices page.

Unfortunately, that’s as far as I’ve been able to get, as the Android app stubbornly refuses to ‘see’ the Lockitron, despite being on the same network.

I’ve triple-checked the Serial Number, and tried variations for the Lockitron’s device name in the app to see if that makes a differnce( long / short / no spaces )to no avail. Freshly-charged new batteries, close proximity to the router, removing other wifi devices from the area also to no effect.

At this point, I’ve exhausted what help the Setup Video can give, as well as at the following links…




Any ideas, @cameron?


@Peter_Ehm have you sent us an email in support? Likely an issue with the serial number.


Thank-you @Cameron, and thanks for your reply - it’s working!

I am having an issue with the settings saving, in regards to ‘handedness’ and ‘location’ but I will try to work those things out over the next week or two on my own - might just be me. :slight_smile:

I appreciate the swift help, and am tickled that I have a Lockitron that’s happy on my door! :slight_smile: