Email from Chamberlain - MyQ app

So I just read that they changed their api backend from V4 to V5. Homebridge plugins broke because of this.
So this may be a temporary problem of instability.
They also may have rolled this out by geo’s differently. Because what you experienced I experienced a couple of days ago. And now things have been very solid.
I’m just guessing here. It might be worth giving it another week. But I can I can understand how frustrating this would be.

How is your experience so far? Do you get activity notifications with the gen3 hub or is that function still not working?

In the MyQ app, the history log does not show Lockitron actions right now. Not sure what their plan is there.
Also the alerts setup screens don’t allow me to select a Lockitron lock yet to setup alerts.
So right now I don’t get notifications.

Also as an update on stability. I’m still experiencing issues around not being able to get current clock status when remote with no ability to open or close it when this happens. Even had an issue last night when eight in front of the door within Bt range where I was unable to open or close it. Status was showing as “unknown” and could not perform any actions. I want to make sure it’s not related to their migration to new API so want to download their next MyQ update and see if they work through their issues.

Thanks for updating us with your experience. :blush:
Please update again if there is any progress to the functionality.

Yet another day, lock does notnwork, status unkown and neither wifi nor bt via phone works , and me trusting this is silly since I dont have a key

When i try to pair it back i get on the lockitron app , invalid serial no matter what i try :frowning: so stuck with intermed working lock :frowning: this really sucks

I went and got a key from my wife, got in, I removed the lock and reset it, then added it agian, and now it works again over bluethooth. I will from now on not trust it, and I am making keys for kids also, so much for keyless entry. They really have to fix this issue, and also the issue with countrys, I talked to the Distributer here in iceland, they have 6 Lockitrons they cannot sell, since Chaimberlain does not send the bridges out of the contry, this distributer is also selling Chaimberlain and has for 10 years…

Thanks for sharing Haffi.
Sounds like the new bridge solution is far from stable. Would be good to hear from Chamberlain what their roadmap for the implementation of lockitron into myq is.
I have asked the question but it remains unanswered.

I more people contact the chamberlain support with these questions maybe they will wake up and start providing us with answers.

I figured out my status “unknown” issue.
When in this state i could not perform any actions to the lock even when in BT range.
what was happening was that the lock would be manually locked and not 100% turned all the way to the lock position. Even though the actual bolt mechanism was 100% out and the door was locked. If the know was in a state of only being 90% turned the lock would show in the app as being in unknown state.
If i turned it 100% to the lock position then the app would update to show as being in a locked state.
If i turned it back to rest at 90% turned to lock position then the app would show the lock again in “unknown” state. I adjusted my lock to try and avoid this from being able to happen. Opened it and messed with the gears a bit.
I also emailed chamberlain as one should never not be allowed to execute an open or close command on the lock even if in some “unknown” state. I should still be able to perform lock and unlock requests.

I feel confident that the status updates are working over wifi and bt. So that is good news for me. However if my lock keeps triggering the app to show up as being in unknown state i will have to also carry keys with me.

1 Like

This was the answer I got from my complaint.


Thank you for contacting Chamberlain. I apologize about the issues that you are experiencing with your Smart Garage Hub Gen 3. Unfortunately, the Smart Garage Hub is not compatible outside of the US or Canada. Please confirm where you are located currently.

Thank you,

The myQ Team

For me I am very close to returning it to the vendor and demanding a refund, since its still within 2years now for me, barly

What does this mean? That the new hub have a geolock and dont work outside of the US?

Just means they wont help, lock works just intermedi.

More reply from them

Good Morning,

While your region does not affect the functionality of your lock alone (when used for local/Bluetooth command), you can experience issues related to remote functionality as the Smart Garage Hub Gen 3 is not compatible in your region. Please let us know if you have any further questions.

I answered how they where going tonsoæve my problem…

So basically this means that the new hub is useless outside of the US.

Very strange way to handle international users of the lock. :thinking:

1 Like

This is the newest reply



Unfortunately there are no plans to produce a Smart Garage Hub Gen 3 for your region. Additionally, the Lockitron Bridge is no longer available.


The myQ Team

So, all international users can just throw their Lockitrons away?

1 Like

Looks that way, mine is very very unreliable. Trying to get it registered back to the lockitron app, just give me bad serial. :frowning:

I finally received my second gen 3 hub. Now I have two hubs and two bolts. Each bolt paired to one hub. Things are pretty reliable. It’s a little slower to respond than when it was paired to the Lockitron bridge. But not by much.
It updates status reliably. This was my biggest issue with the Lockitron bridges and is why I’m sticking with the myQ app.

The one issue I have which I’m having with One of my locks is that on a rare occasion I’m getting that lock into an unknown status situation. When the myQ app shows the lock in this “unknown” status I can’t perform lock or unlock operations via the App. The cause for the unknown status for this one lock I believe is a hardware issue. I think something is up with the gearing mechanism that puts the lock in this state. It was happening a lot at one point and I messed with the gears a bit to try and fix the issue. Now it’s not happening much at all. Not sure if I’ve fully fixed it. Fingers crossed.
So my main complaint is that I can’t force a lock or unlock operation even if the lock is in an unknown state. I’m going to speak to chamberlain about this. If I could force perform the unlock operation then the lock would actually still work when in this app reported unknown state.

So all in all I’m happy with the setup.
The auto open functions that Lockitron was never able to get going reliably, or lock unlock history or support for more than three guests to have control are not options right now.
But I’m ok with these features missing. Hence ok with MyQ app setup.

If anyone wants to ship me their Lockitron bolt for a discount I’d be interested. Need one more for a side door.