Lockitron Community

Firmware update


#1

Hey all, just got mine in , installed and its asking for new firmware.

FW running is 1457357935

However no matter what I do it just says Downloading firmware…

and spinns…

I have checked my network logs and it opens something towards amazone but then nothing happens.

I am located in Iceland, What can I do here…

Are the network servers down ?


#2

@haffi PM me your serial number. It’s likely that the server cached a bad file for your firmware update which I need to manually clear. This happens rarely.

You might also try uninstalling and re-installing the mobile app.


#3

@cameron Thanks , let me know when I can test again ! :slight_smile:

Thanks !


#4

@haffi just saw your email in support; I purged all the firmwares for your device. Could you try again?


#5

@cameron

Just pushed the firmware update.

Still says downloading, Are there any otherways to download and push the firmware ?

7 mins and still spinning not sure if any thing is happening, I am on fiber(1G/s) btw but speed to USA is normally around 200-300 mb/s


#6

@haffi hmm, I am wondering if a server is being blocked somewhere along the lines…might be cloudflare or something like that. Have you tried doing the update over cellular?


#7

yes, tried over Celular , bounched via USA proxy , and another of my proxies here in Iceland.


#8

@haffi hmm ok. I have to do some more digging here. I haven’t heard of this issue cropping up for other users, but it may be server related.


#9

What is the update big ? what does the app do after it gets the file ? Will I get a question for next step like push via Bluethoot?

Will the bridge help with this at all i.e. another way of updating ?

Again thank’s for the help :slight_smile:


#10

No, not big. The app switches to a screen with a large, round loading bar and a button (I think it says “Upload”). Bridge cannot carry out updates.


#11

not sure who 104.24.96.215 is but it traces through

6 c02-d02-bcast.c.is (217.151.190.155) 3.853 ms 3.397 ms
rix-tg-gw.cloudflare.com (195.130.211.50) 4.012 ms
7 104.24.96.215 (104.24.96.215) 3.236 ms 3.213 ms 3.908 ms

also see

ec2-54-88-252-218.compute-1.amazonaws.com

23:31:59.953884 IP 104.24.96.215.https > 192.168.10.190.63536: Flags [.], ack 7839, win 257, length 0
23:32:00.735572 IP 104.24.96.215.https > 192.168.10.190.63536: Flags [P.], seq 21207:21718, ack 7839, win 257, length 511
23:32:00.735606 IP 104.24.96.215.https > 192.168.10.190.63536: Flags [P.], seq 21718:21757, ack 7839, win 257, length 39
23:32:00.735619 IP 104.24.96.215.https > 192.168.10.190.63536: Flags [P.], seq 21757:21795, ack 7839, win 257, length 38
23:32:00.754686 IP 104.24.96.215.https > 192.168.10.190.63536: Flags [P.], seq 21757:21795, ack 7839, win 257, length 38
23:32:00.820678 IP 192.168.10.190.63536 > 104.24.96.215.https: Flags [.], ack 21795, win 4086, length 0
23:32:00.820746 IP 192.168.10.190.63536 > 104.24.96.215.https: Flags [.], ack 21795, win 4086, options [nop,nop,sack 1 {21757:21795}], length 0
23:32:04.952216 IP 192.168.10.190.63536 > 104.24.96.215.https: Flags [P.], seq 7839:8040, ack 21795, win 4096, length 201


#12

what address is behind the firmware that way I can trace the route and debug this further


#13

I tested now from another network physical, still the same error :frowning:


#14

@cameron Here is a pacet trace from my end.

lockitron-fimrwaredownload.pcap.zip (55.0 KB)


#15

@cameron

What are the next steps here ?


#16

@haffi I’m diagnosing on this end but don’t have a solution at this time.


#17

I am having the same problem.

Just bought a new one. Firmware says 0. Bridge was not communicating with the lock, was advised to update the firmware. But when I tried I get stuck at downloading firmware. Left it at the screen for more than an hour. Nothing happens.


#18

@cameron got this in his scope, we’l just have to wait with firmware updates til this is fixed.
I think all the info from us has been given.


#19

@haffi @cameron just to chime in, I am also living in Iceland and just got mine 3 days ago. Same firmware as Haffi and same problem. Tried to boot up in firmware update mode on the lock but that did not help, also tried multiple Android devices.

In case it helps in the troublshooting, after reading your discussion about traceroute and possible server issue I tried to pop up in USA and UK over VPN on my phone and see if the update succeded then but that did not do the trick.


#20

@wattocs @haffi @garpur please try again now.