Lockitron Community

iPhone 6 plus / iOS 8 Instant App crash


The app works as long as I have bluetooth disabled. However, if bluetooth is on, the app instantly crashes. I have tried:

Logging out and logging in again.
Deleting and reinstalling the app.
Restarting the phone.
Reflashing the bluetooth firmware on the device.
Reflashing the firmware on the device.

Interestingly, turning on bluetooth while already inside the app will trigger an instacrash as well.


@stephennelson384 sorry, have you tried updating the main firmware right after the Bluetooth firmware? This would happen when Lockitrons were advertising our old Bluetooth characteristics with newer versions of the app. Lastly, could you post what you see in a diagnostic app like LightBlue?


My current attempt at reflashing the bluetooth seems to be stuck at 77% for about an hour. Should I wait or take another action?


Remove and replace a battery - it should restart. Keep an eye on it to see if it gets past 77 - any WiFi trouble in the past?


Restarted. No progress past 77.

No wifi trouble that I know of in the past.


Okay, request another BLE update, then remove and replace a battery. Has it shown anything below 77%? This time if it gets stuck there we might want to let it sit for a bit.


So I should request another update, then immediately remove and replace a battery?

I’ve done this a few times now trying to get this to work, and I’ve seen percentages below 77, and last night it got to 100


Exactly - then I would see if its advertising. I can also look and verify in logs whether or not it could be some web error in between.


Ok, requested, battery pulled and replaced.


Okay, I took a look at the logs and see it got stuck at 83% due to a network disconnect. Is it far/close from/to the router? I would recommend popping it of the door for the update and moving elsewhere.


Trying again. It was already off the door, sitting on my desk. Moved it closer to the router now


Now it seems to have stopped again at 31%


It’s been offline for six minutes - how close to the router is it? It can, oddly, be too close. Do you have any repeaters set up?


seems to have been a battery issue, came back to life when i jiggled them


Hmm - any of the battery springs look out of place?


Should I remove the batteries and investigate? It is responding to the side button now, so i know it has power. Is it still showing as offline?


Still showing as offline - if it responds to the side button it has enough power to connect. Does the WiFi LED blink any colors/patterns?


No, it is currently blank


When you remove and replace a battery does it blink?


Blinks orange and green, then just green