Lockitron Community

Lockitron android app stuck on "Determining current location"


The app is always stuck on determining current location. I go to settings - location and sense- then I tap on use my location. I checked the services is allowed and is running. Google maps works fine. I also tried calibre my location. Same issue.

I have a Samsung note 3 and it’s android version 5.0

Sense Set-Up and Location Error?

@Ant81584 we’re seen a couple reports of this and are looking into it.


This is happening to me on three different phones. oh, and where is my bridge? Poor experience.


@s.dewart what are the three makes and models of phone?


An sony Xperia z2 and z5 as well an asus zen 3 zoom does not have option to calibrate. I have answered your question, no you mine. My bridge? Really dont want to wait three more years for that.


@s.dewart happy to stay on topic here regarding the determining location bug, not conflate things with Bridge questions. Missing the option to calibrate entirely means that the app doesn’t think you’re the owner (are you logged in via the owner account? If so, try logging out and back in again).


Any update on the fix?


Same issue. I just bought and installed the Bolt and can’t use Sense at all. Nexus 6P.


I never could get it to work on my Nexus 6p either, and now it still doesn’t work on my Note 8. I’ve so far been unsuccessful in using the calibrate / sense options at all.


@cameron still waiting on the update


New Xiaomi phone running nougut will not determine location either.


I’m trying to set up the Sense and All I get is “Determining current location”.

Yes, I do have Bolt and Bridge. All other features work fine. My permissions are set and in my location service’s Lockitron requested location.

Is there something I missed?


Same issue here…Samsung S7 and using latest Bolt + Bridge


I am also running into this issue. I have a Samsung S8


@cameron still waiting on the update


seeing the same issue with a nexus 5 running nougat and a iPhone 6s running 11.1


@osidak the iOS bug just cropped up, we have isolated a fix and are waiting on App Store approval.

@Ant81584 doing more digging on this.


How about on the Android side of things as we also use Android.


Hi folks - we have a fix for this that we’re testing in beta. Please let me know via DM or via support@lockitron.com if you would like to test the beta for Android.


So I was able to try it and it’s working okay now. Also tested latest from ios. It was crashing on ios, but it’s not doing that anymore. Thanks for finally fixing the issue.