Lockitron Community

New Firmware update to 1533846445


#21

@cameron any chance I can test rolling back firmware? Since I have two Lockitron bolts with bridge, it’s strange that I’m seeing this same behavior on both of them. And I know the bridges are working because I can lock and unlock via Wi-Fi with Bluetooth turned off on my phone. I can lock and unlock via hkmebridge or via the lockitron app with BT off.


#22

klidec: Good to know that you have reliable lock/unlock functionality from the Bridge. I’ll try sending a note to the Support team to see if they can provide assistance.

With regard to manual lock/unlock log entries. This worked for me exactly twice immediately after installing 1496963301. I have ONE late night entry for “Locked by hand” (June 6) and another for “Unlocked by hand” the next morning. It never worked again.


#23

I don’t know if in prior firmwares the lock by hand and or unlock by hand would ever register in the activity log. But what I do know that when checking lock state from work via Wi-Fi or at home via Wi-Fi (BT off on phone) the app would show the actual correct lock/unlock state of the lock. Now it doesn’t. It only registers the correct lock unlock state if at some point I connect to the lock with my phone via BT.

While it would be nice to register manual lock and unlock states in the activity log and get notifications when they happen. I’d at the very least like to always have the correct state of the lock when connected via Wi-Fi remotely. That’s the main problem I have.

Hoping @cameron can comment.


#24

@cameron any ideas on my situation? I even replaced the power supply. Didn’t change the behavior. Both bridges refuse to get or update lock status when I’m remote and the lock was opened or closed manually.


#25

@klidec I don’t have further updates here; I will be working with the firmware folks in a couple of weeks and I will bring up this issue. Unfortunately there is no “rollback” feature :confused:


#26

Thanks for the update.
If you need me to test any new firmware trying to address this, let me know.
My family for now is ok with the status not being correct when remote.


#27

What is the “normal” Bridge LED status when idle? I have NO LEDs lit or blinking. I can ping the Bridge successfully, but I can not connect via WiFi.


#28

I have the same experiance, bt works fine, bridge does not know when manual unlocked, app crashes if i load it and it detetects the lock like stated above. Tried new psu no different, I think this is after new update of lock


#29

While I’m not glad to hear you are having the same issue, I’m glad to hear it’s not just me.
I’m 100% sure that this issue is new as i always saw my lock status update when remote or when checking via Homekit/homebridge (which only checks via WiFi). I suspect it’s the firmware of the lock or could be the bridge firmware.


#30

@cameron any news on this? The lock or way to debug this bridge issue ? If I use the bt in phone lock seams to work , but wifi bridge looses the status of the lock and teels me the wronb state and is not trust worthy. Then the app crashes. And I never know if my door is locked or not til I get home , so I would have to say this is quite urgent in need of fix.

Thanks


#31

@haffi this is a lock issue or web server issue; no changes have been made to Bridge lately. Investigating with the firmware folks this week.


#32

@cameron Wondering if there were any discoveries around the issues that have crept up with remote updating of actual lock status.


#33

Same here. Lots of us with this issue.


#34

@klidec I’m still waiting to hear back on confirmation but it sounds like a bug crept in how messages are parsed. I will follow up as I know more and anything about a resolution.


#35

Also I notice that the battery is still showing 35% after replacement of batterys one week ago.