Lockitron Community

Sense and location services stoped working?



I’ve recently updated the lockitron app on my ios device. Immediately after that the sense function stoped working. I think it has to do with my location settings and for some reason not being able to set it to “always use my location” anymore. I’m only left with two options, “never” or only “when in use”. I’ve tried rebooting, reinstalling all I can think of but it remains the same. I’m I the only one with this issue? I have an old ipad as well with the latest version of the lockitron app and all the location settings is still the same after the update.

Would appreciate some assistance on this one please.

/ Oskar


I’m seeing the same thing going. I had Sense working rather reliably, but the latest update removed the ability for me to grant the app access to my location.

In the Diagnostic tab of the app, Location shows as ‘off’ and when I tap and go into my Location settings I cannot give the app access to my location at all times.


Hrm… I’ve just noticed this too on my end, changing to a new phone. I hadn’t set up Sense yet, but I see it not having location permissions.

Previously when I’ve had issues similar to this with other apps, I’ve had to uninstall/re-install them to get the permission prompt again.

When I get back home later today, I’ll try some strategies to see if I can get it to trigger.


Anything new on this one? Tried emailing directly to lockitron support but no answer there…


Following up a bit late on this one - there was a shift in permissions with iOS 11 that we didn’t account for in the last release. We have a release that just passed approval which resolves this.



Any update on this issue to get Sense back up?


I don’t remember exactly how mine got enabled again, but I have some suggestions.

First, if you update to the latest version of the Lockitron app on iOS, it should prompt you to re-enable Location Access.

If it doesn’t, try doing the following:

  • Open the app, open the menu
  • Go to Support, tap on “Review Permissions”

If nothing happens yet, try going to the Settings page for the lock, and open the Location & Sense page.

It should prompt you in one of these spots.


My apps automatically update on our phones. Is there any changes on the iPhone X permission from older phones? Or maybe some apps didn’t install properly since I updated a month ago.

Will delete the Lockitron app and try again.


Anyone here using two iPhones with Sense turned ON and working for both phones? I find that the Sense doesn’t work if one of the phones are home and the other is just coming home. It won’t unlock.

I have to shut off the Sense in one of the phones at home to make sense work at all for the other.

Any thoughts?


I have two phones, and it seems to work well in this situation. It sounds like the one phone is keeping its connection alive, but it really shouldn’t be.

Do you have any of the “special” options turned on, like “Eager Connection”? It might also be worth calibrating location with both phones, at the door. Doesn’t have to be at the same time.


The setting defaults to eager connection so I took that out.

Also you can only calibrate the location from one phone though. I believe the main admin at least from my app with two separate log ins unless you use only one log in account?