Lockitron Community

Sense & Firmware 1496963301



Lately (a few short weeks) I’ve been having issues with the Sense not working again. Nothing has changed set-up wise. We’ve been chugging along. When we reach home, the door senses the phone and unlocks with no issues. Until the past few weeks it just stopped sensing. I tried everything from removing batteries, restarting Bridge, etc.

Then today I decided maybe there’s a new firmware. The app said I have the latest firmware and if I want to reload it. I pressed yes just to try and trouble shoot my above issue.

After it was done, it shows I have a new firmware 1496963301 which is different from the firmware I just have which the app said is the latest one already.

Can you shed light on this new firmware please and possibly a fix for sense? Thanks.


Sense still didn’t work. Left the house for dinner. Came back and it doesn’t open any longer. Sigh.


@oneframe there are minor changes in the firmware to help with Sense, but most of the failures are caused by faults in the mobile apps. We’re doing a deep dive on the iOS failures right now.


Just wanted to throw in that the same is happening for my iPhone and my wife’s. Sense was working reliably (mostly) up until this update. I very much appreciate the effort being put into this project.


@dverde hmm, it’s unlikely the update caused the issue on the lock side (it’s now better optimized for Sense on iOS); it’s more likely that there is an issue client side. I recommend (1) rebooting the phone and if needed (2) uninstalling and reinstalling the app. Then make sure Sense is re-enabled.

iOS or Android?


@cameron I did as suggested… reinstalled the app, rebooting before and after, recalibrating, and making sure Sense was again set to Proximity Unlock/Eager Connection. Despite the effort, Sense worked exactly once in the last 4 days. The phone is running iOS. About to do the 10.3.3 update and see if that affects things.


@dverde (and for anyone else with iOS) - One thing to note, if your iPhone is plugged in and charging when you get back to your lock, Sense will not unlock the door. An example could be charging your phone in your car on the way home, or listening to music over USB.

There are some tools you can use to check what’s happening on iOS.

  1. Go to the Lockitron app, and in the menu on the left, find “Support”

  2. Under “App Troubleshooting”, check “Permissions”. Make sure that location reads as “On”.
    2 a) If location is off, go to Settings > Privacy > Location Services. Locate “Lockitron”, and set the permission to “Always”.

  3. Go back to “Support”, and under “App Troubleshooting”, open “Diagnostics”. Turn these three on, but with caution - you’ll get a lot more notifications on your phone. The most important are “Did Enter Region” and “Bluetooth State”.

When you arrive back at your “home” or “Sense Radius”, you should see a message along the lines of “ENTER region for abc Lockitron”, and then when close enough to connect, “Connected with Bluetooth for proximity unlock”.

If there’s any error of any kind, you’ll get notified at this stage.

Here’s an oldie (but a goodie) that I wrote last year:


@dverde do you notice any performance degradation when trying to control the lock with the app in the foreground?

We’re doing a lot of testing on iOS Sense now to get to the bottom of failures; all of our test locks are on the latest firmware build and so far 100% of the failures we’re encountering are app side. It’s possible that lower level iOS APIs are having trouble.

A deeper explanation on why we’re suspect when these issues crop up right after an update - in order to carry out an update the lock is put into a special “DFU” (device firmware update) mode which hosts an entirely different set of Bluetooth characteristics. Once the update is complete, the lock returns to normal. We notify iOS of this characteristic change via a special flag in the lock’s advertising data.

Despite this, we still see cases where an iPhone fails to connect to a lock after DFU; we’re not privy to the lower level causes of this. That said, the solution is typically anything as mild as turning Bluetooth on and off to rebooting the phone, or, more drastically, uninstalling and reinstalling the app.

Keep in mind - if you have any trouble connecting to the app in the foreground (with the app open), then you definitely will have trouble carrying out a Sense command.


I switched on diagnostic notifications as Anthony has suggested and will report back what I find, and will also look at what having the app in the foreground does. I will also try reinstalling the app again after I run the iOS 10.3.3 update.

I should mention there is an outlier condition. When I’m approaching my door, I’m in a corridor where there’s no cell signal and likely no GPS. However, at that point, I’ve long crossed the geofence boundary. I presume this isn’t an issue since, before the last firmware update, the proximity unlock would trigger even when I was a good 30 to 40 feet from the door.

I can also see my wifi network at this point. So, allow me to ask: I’ve delayed setting up Bridge… could this be a critical piece in helping solve the matter (i.e., is there a wifi assist)?

This is likely a non-sequitur, but I’ve noticed that the delay between the app connecting with the lock (on the interior side) is shortened when I physically turn the latch… as if the connection delay (“Searching”) is mostly getting the lock to “wake up”, which the manual latch-turn gives the appearance of doing. Just another observation.

Again, I will experiment and report what I find over the next few days.

Thank you for the attention and support you’re giving this.


Just want to chime in that I’ve re-installed the firmware thrice already including one more today. Removed the app. Reinstalled. Re-set Sense. Re-start iPhone. Etc.

Hasn’t been working reliably unlike before where it works everyday. Now it only worked once probably 3 days ago and then never again.


@oneframe do you have the diagnostic notifications on?


Behavior from last few days of having diagnostics on…

I receive the region entry notification, and then, as I come into vicinity of the lock, I receive a notification stating that the lock failed to authenticate.

So, this was happening predictably the last 3 days until today when Sense engaged and opened the lock.

With app in the foreground, it took almost a full minute for the lock status to show up. The status appeared to hang in the “Today View” (aka, Lock Screen) widget, when I tried to use that.

Again, noticed that turning the latch would force a status “wake-up”… but sometimes it would immediately return to polling.

Battery at 66%.


I turned on the diagnostic notifications on my phone and got a bunch of notifications that are all the same. I realize after reading the above that the diagnostic notifications should be on the phone using the Sense.

Because my wife is the one using Sense and she said it’s been working again for probably 3 days straight already, I won’t turn it on to annoy her until it start not working.


@dverde next time you get a failure to authenticate, can you wait a moment or two and see if more failures come through or if the command completes?

The lock status showing up is odd, but to be honest I’ve never waited that long. If I see something like that I’ll leave that view and go back to the lock screen.


Uploading a screen capture (below). Same failure notification, but this time, I waited a few minutes outside the door to see if it would try again as Cameron suggested. It didn’t, and I resorted to opening the door with the Today View widget, which readily connected with lock… unlike this morning.

In the latter case, upon leaving this morning, I swiped to the Today View widget while I had the door open. It first showed the unlocked status, but then went back to polling. Then it showed the wrong status (locked), polled again, and returned with the correct status (unlocked) for me to lock the door.


@cameron, I am experiencing the same error message. Right after I said it’s working fine again. It worked for two days and then none again. So I turned on the diagnostic message and it says exactly as above - failed to authenticate.

When it worked, it says:

Connected to lock.

Unlocked Lock.

When it doesn’t work, it says:

Enter region.

Connected to lock.

Failed to authenticate.


@oneframe yeah, that’s really a diagnostic message (it’s common to get an unlock success after several initial failures to authenticate). We don’t have a root cause on why it’s failing to retry after that or why it might work one time and then fail subsequently.

Sometimes it’s due to weak signal, however, in that case the app will typically retry and succeed at a later time.


@cameron How long should it be waiting between retries? If it is retrying, will we see the diagnostic messages repeat, or does the time just update? I’ve waited a few minutes after seeing the failed to auth message and seen no change. Should I be waiting longer?


@Jczippy yes, you should see the messages repeat. It should happen within less than a minute.


I am having the same issue as you. i have updated to the latest Firmware since then Sense has not worked at all…